OpenSSL announced that it will use the Apache License 2.0 license

Posted: 24/03/2017 in Uncategorized

The OpenSSL project announces a change in license from Apache-like license to Apache License 2.0 to make it easier to use free-source software projects and products. OpenSSL is the most widely used encryption library, it was previously used license is OpenSSL License and SSLeay License, which OpenSSL license is the Apache License 1.0 license, and SSLeay license is 4-clause BSD.

These two licenses are not compatible with the GPL license, and the GPL software requires an exception when using OpenSSL, and the Apache License 2.0 is compatible with the GPL. After modifying the license, OpenSSL will be more freely integrated into the GPL software. The OpenSSL project indicates that the next few days will begin sending mail to all project contributors requesting them to approve the change.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s